Users Unable to Access Dentally Vision in Australia

Incident Report for Dentally

Resolved

We have identified the root cause and have confirmed this to be isolated to a single site. No widespread impact is expected.
Posted Jul 31, 2025 - 09:01 BST

Update

We have identified the issue and believe it to be isolated to a single practice. We are still working to ensure no further negative impact.
Posted Jul 31, 2025 - 08:47 BST

Investigating

We have received reports of Dentally Vision being unavailable in certain cases in Australia. We are currently investigating the issue and will post further updates shortly.
Posted Jul 31, 2025 - 08:33 BST
This incident affected: Dentally Vision.