Dentally Portal Concierge experiencing loading issues.

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Sep 17, 2025 - 11:17 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2025 - 10:21 BST

Investigating

We are investigating an issue with Dentally Portal Concierge.
Posted Sep 17, 2025 - 09:08 BST
This incident affected: Dentally Portal.