Dentally Vision not loading as expected

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 10:31 BST

Update

This issue has been resolved and Dentally Vision is fully functional and loading correctly.
Posted Jul 28, 2025 - 09:40 BST

Investigating

We are aware of an issue with Dentally Vision not loading as expected - we are investigating and will update you soon.
Posted Jul 28, 2025 - 09:19 BST
This incident affected: Dentally Vision.