Dentally Vision not loading as expected

Incident Report for Dentally

Resolved

Our monitoring has confirmed no further issues and this incident has been resolved.

We apologise for any inconvenience caused.
Posted Sep 19, 2025 - 15:05 BST

Monitoring

We’ve identified the cause of the issue with Dentally Vision and it has now been resolved. Our monitoring shows everything is back to normal. We will continue to monitor to confirm this and will close this status as resolved shortly.

If you experience any further issues, please contact our Support Team via Support Chat in Dentally and we’ll be happy to help.
Posted Sep 19, 2025 - 12:02 BST

Investigating

We are aware of an issue with Dentally Vision not loading as expected and is presenting a white screen - we are investigating this issue as a high priority and post further updates as soon as possible.

We apologise for any inconvenience caused.
Posted Sep 19, 2025 - 11:44 BST
This incident affected: Dentally Vision.