Northern Ireland: Issue with HSC NI claims submission.

Incident Report for Dentally

Resolved

HSC NI have confirmed the issue has been resolved. Claims are now being sent properly. Any claims sent during this outage will be automatically resubmitted.
Posted Sep 17, 2025 - 09:14 BST

Investigating

We are aware of an issue submitting claims to HSC NI. HSC are aware of an issue at their end and are working to resolve it. Once resolved all claims will be automatically resubmitted.
Posted Sep 16, 2025 - 15:53 BST
This incident affected: Claiming Services.