Delay in seeing Consent/Estimate forms and Medical histories & payment records

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 18:00 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2026 - 16:47 BST

Identified

We are currently experiencing a delay where certain new data is not appearing when expected.
The cause has been identified and a fix is in progress.
All data will re-appear once delay is resolved.
Posted Apr 14, 2026 - 15:40 BST
This incident affected: Dentally Application and Dentally Portal.