APAC Electronic Claiming Issue

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Jul 21, 2025 - 03:33 BST

Update

Claiming Services and the Dentally Application are operational.
Posted Jul 21, 2025 - 03:31 BST

Investigating

We’re currently investigating an issue affecting electronic claiming. In the meantime, claims can still be processed through Dentally but will need to be recorded manually. Our team is working on a fix and we’ll update you as soon as this is resolved. Thank you for your patience.
Posted Jul 21, 2025 - 01:57 BST
This incident affected: Dentally Application and Claiming Services.